[developers] Compiling and running LKB from source under windows

Stephan Oepen oe at ifi.uio.no
Tue Apr 30 09:08:10 CEST 2013

dear mostafa,

i'm copying the DELPH-IN ‘developers’ list, in part because others may have
suggestions, in part for archiving purposes.

it's been ages since i validated compilation in other lisp systems than
allegro common lisp (on linux); i do not know of others who have tried this
in recent years either.

hence it is quite possible that ‘newer’ code (like the lexical database) is
not properly conditionalized for non-allegro environments. i am afraid one
would have to know a little lisp and work out how to disable loading
of (and possibly references to) the lexical database code.

in principle, it should still be possible to compile the LKB core in other
lisps, but at present we only have resources to ‘support’ allegro and linux.

two general suggestions, though: i would recommend using ‘latest’ code and
either allegro (which is available for windows and used to work a few years
ago) or steel bank common lisp (sbcl).

incidentally, there is an implementation of the DELPH-IN formalism, called
agree, in C# with excellent windows support.  it's still under development,
and i am unsure about availability just now; please look for ‘AgreeTop’ on
the DELPH-IN wiki.

best wishes, oe

On Tuesday, April 30, 2013, Mostafa Gomaa wrote:

> I am trying to compile the LKB source using the instructions on the
> website, I am using the stable version of the source. I was successfully
> able to compile the source however, I received some "continuable errors"
> regarding lexdb source files (I checked the source code, and didn't find a
> lexdb directory). The compilation was then over with 0 errors and 3108
> warnings. I then tried to load an example grammar by typing
> (read-script-file-aux filename), but I received an error (TYPEP: invalid
> type specification EXTERNAL-LEX-DATABASE). Another problem I faced was when
> I exited my lisp environment, and then tried to load lkb again using
> (load-system "lkb") I received an error that the function load-system is
> undefined. I am using CLISP by the way. If anyone can shed some light on
> how to fix these issues, I would be very grateful. Thank you very much for
> taking the time to read this email.
> Regards,
> Mostafa Gomaa

+++ Universitetet i Oslo (IFI); Boks 1080 Blindern; 0316 Oslo; (+47) 2284
+++    --- oe at ifi.uio.no; stephan at oepen.net; http://www.emmtee.net/oe/ ---
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.delph-in.net/archives/developers/attachments/20130430/4aebf8f0/attachment.html>

More information about the developers mailing list