[developers] I may as well report it to you...

Alex Lascarides alex at inf.ed.ac.uk
Wed Oct 12 14:55:45 CEST 2005

Dear Stephan,

Please forward this email to the appropriate email address if I
shouldn't be contacting you directly...

I'm trying to view parses from Redwoods and other test items with
tsdb.  My installation of tsdb was working this morning, but since
installing Redwoods things have gone awry.  Here is how...

I did what was instructed on the Redwoods website:

wget http://lingo.stanford.edu/ftp/etc/install
bash install --redwoods

(I didn't have to set DELPHINHOME because that's already set).
Redwoods appeared to install fine; I got no error messages.

I then started to run the LKB.  I did this by opening an emacs window
and doing esc-X lkb.  lkb::*cvs-version* shows I'm running the
following version of the LKB:

"$Date: 2005/10/05 19:54:30 $"

I then loaded the ERG (Version from 05-Sept-05).  I needed to load the
grammar to do other things.  I loaded it using the  LKB top window,
selecting "load", "complete grammar" and then going for
~/delphin/erg/lkb/script.  The grammar loaded successfully.  I can
parse things using the command do-parse-tty in the emacs window.

I then did esc-X itsdb.  Everything seemed to load fine (no error
messages anyway), and I get the tsdb podium, with a whole bunch of
test suite instances showing.  Having installed Redwoods, this list of
test suite instances has grown to include the redwoods ones (e.g.,

If I click on redwoods/jun-04/vm6/04-06-11, and then click on "Browse"
and "Test items", I get a message "retrieving...", and then a prompt
asking: table layout may be slow...continue? (yes/no).  I type "yes",
and sure enough, as should happen, I get a window with all the items
in this test suite in it (items in red, as they should be).

OK.  So here now are the errors.  While this morning I could double
click on an item in a test suite and get its parses, now nothing
happens.  I get the following error message in the emacs window:

out-of-date profile `redwoods/jun-04/vm6/04-06-11'.

I thought that maybe it was a problem with the redwoods stuff I had
just installed, so I tried it on lingo/nov-98/csli/99-01-20/lkb.
Before I installed Redwoods, this would bring up a window of items
that I could click on to get their parses.  Now it brings up a window
of items, but when I click on them I don't get the parses.  I get the
same error message as above.

The second error is that when I quit tsdb, my whole X-windows
application crashes, logging me out of the unix system etc.  The same
thing happens however I quit the processes (e.g., if I quit from the
LKB window).

Do you know what I'm doing wrong?  Should I have prepared the test
suite instances in some other way?  


More information about the developers mailing list