[developers] I may as well report it to you...

Stephan Oepen oe at csli.Stanford.EDU
Thu Oct 13 07:59:07 CEST 2005

hi alex,

> Please forward this email to the appropriate email address if I
> shouldn't be contacting you directly...

i re-sent your message through the DELPH-IN `developers' list, which we
increasingly use for discussion around problems with various DELPH-IN

many thanks for the detailed problem report; nice work!

> OK.  So here now are the errors.  While this morning I could double
> click on an item in a test suite and get its parses, now nothing
> happens.  I get the following error message in the emacs window:
> out-of-date profile `redwoods/jun-04/vm6/04-06-11'.
> I thought that maybe it was a problem with the redwoods stuff I had
> just installed, so I tried it on lingo/nov-98/csli/99-01-20/lkb.
> Before I installed Redwoods, this would bring up a window of items
> that I could click on to get their parses.  Now it brings up a window
> of items, but when I click on them I don't get the parses.  I get the
> same error message as above.

the problem here is that the [incr tsdb()] database scheme has changed
recently, and when you installed Redwoods now, you ended up with newer
[incr tsdb()] code.  the effect is that (rightly) the system will not
process old-style profiles.  in your case, clicking an item in red ink
from one of the [incr tsdb()] tables requests processing (i.e. parsing
by default) that item interactively.  there is no good reason why the
software should refuse to process interactively, and i will fix that in
a future release (however, non-interactive processing of old profiles
remains undesirable).

however, in your case i doubt you actually wanted to parse those items.
in order to browse trees from a Redwoods treebank, you will need to use
the exact version of the grammar (i.e. ERG) that was used when creating
that treebank.  then, you expect to the system to retrieve the tree(s)
that were considered intended by the annotator and re-build their full
HPSG analysis: to do the latter, the original grammar is required.

when you installed with the --redwoods option, i think there should be
a copy of the current `Redwoods ERG' (jun-04) as `erg.jun-04'.  if you
really intend to work with those treebanks (rather than the newer ones
dan has made available within Rosie recently), you will need to load
that version of the ERG.  as a rule of thumb, the ERG version needs to
match what you see as the `grammar' value in the output produced by
`Browse | Test Runs'.  often, the version is also encoded in the name
of a profile, e.g. `redwoods/jun-04/vm6/04-06-11'.

having said all this, how do you actually browse trees from a profile,
once you have matching grammar versions?  in principle `Trees | Browse'
would be the right command, but you will find that greyed out :-{.  in
practice, `Trees | Annotate' is what people use, but you will find that
to produce the same `out-of-date profile' message, just because we aim
to preserve read backwards compatibility on old-style profiles but not
write access.  i guess i should really activate the browse option now!

> Do you know what I'm doing wrong?  Should I have prepared the test
> suite instances in some other way?  

well, not really.  you simply got caught between two rather different
versions of [incr tsdb()].  if you want to parse interactively, just
create a new, empty TS instance through `File | Create': new profiles
will of course allow processing, both interactive and batch.  

in order to view old treebanks, you will have to wait for a new version
of [incr tsdb()] that allows browsing (and possibly exporting) from old
treebanks.  i will put that on my agenda, but can only hope it is not a
priority from your point of view?

> The second error is that when I quit tsdb, my whole X-windows
> application crashes, logging me out of the unix system etc.  The same
> thing happens however I quit the processes (e.g., if I quit from the
> LKB window).

very curious.  this is using the MacOS X X11 server?  which version?  i
presume you use ssh(1) to connect to the machine running [incr tsdb()]?
can you try `ssh -Y' instead?  does it crash deterministically?  this
is, of course, strictly speaking a MacOS X11 problem (since no remote
session should have the ability to do gross local damage), but i wonder
how we can best make progress in analyzing the problem.  i am actually
moving to a MacOS environment myself, so i will see whether i manage to
reproduce this problem ...

                                                       all best  -  oe

+++ Universitetet i Oslo (ILN); Boks 1102 Blindern; 0317 Oslo; (+47) 2285 7989
+++     CSLI Stanford; Ventura Hall; Stanford, CA 94305; (+1 650) 723 0515
+++       --- oe at csli.stanford.edu; oe at hf.uio.no; stephan at oepen.net ---

More information about the developers mailing list