[developers] ECL compilation

Bernd Kiefer kiefer at dfki.de
Tue Feb 14 09:56:24 CET 2006

> I can confirm that ecl 0.9h builds on amd64 architectures without this
> patch.Perhaps this is a problem with the particular distribution you are 
> using. I had success with it under Ubuntu Breezy using gcc 4.0. The only 
> configure flag is set is --with-cmuformat. What compiler and 
> distribution did you experience this problem with?
> Eric

This was SuSE 9.2/gcc 3.3.4/AMD Opteron, but i think it's more a
problem of the pre-installed libgc (Boehm-Weiser gc)

Well, i had a request upon this (and, besides, a problem myself), so i
thought this would be useful information.

Here is another fix for a problem that was on the list; maybe you've
solved that too already and i didn't hear of it:

Compilation of pet with ecl on the above-mentioned system failed when
petecl.c included ecl.h. I submitted the following bug report to
sourceforge this morning

When i tried to embed a ecl-built dynamic library,
i had problems on a AMD64/SuSE 9.2/gcc 3.3.4 system
because there seems to be another system-wide file
named config.h. Compilation of my source code including
ecl.h failed because cl_fixnum was not declared because
the wrong config.h file was included.

I would suggest renaming the config.h to ecl_config.h
(that fixes the problem) to make it distinguishable
from any other system-wide config.h

So, what you have to do to compile pet properly: change the 
#include <config.h> in lib/h/ecl.h to #include <ecl_config.h>
and rename the lib/h/config.h to lib/h/ecl_config.h


Bernd Kiefer                                            Am Blauberg 16
kiefer at dfki.de                                      66119 Saarbruecken
+49-681/302-5301 (office)                      +49-681/3904507  (home)

More information about the developers mailing list