[developers] PET 0.99.12 + MRS Build Errors SOLVED!

Eric Nichols eric-n at is.naist.jp
Thu Apr 27 08:21:50 CEST 2006


The errors you get suggest the preprocessor code is still being
compiled in. Try running 'make clean' (or better yet, 'make
distclean') in the directory where you ran configure.
For the record, I configured mine with the following flags:

./configure --with-ecl=/usr --with-mrs=$(HOME)/tmp/lkb/src
--with-tsdb=/usr --with-xml=/usr --enable-qccomp --without-lexdb

My ECL, MRS, and TSDB locations are irregular, but you get the idea.

Good luck,


On 4/27/06, Francis Bond <fcbond at gmail.com> wrote:
> G'day,
> Did you run  "make clean"  in between?
> I was getting the same error as you, but it went away after I used the
> --without-preproc flag and redid everything.  My parameters were:
>  ./configure --with-tsdb=$DELPHINHOME/lkb  --with-xml=/usr/lib
> --with-icu=/usr -with-ecl=/usr --enable-qccomp --without-preproc
> > I don't know what else should I do.  Can you give some suggestion?
> I hope this helps.
> --
> Francis Bond  <www.kecl.ntt.co.jp/icl/mtg/members/bond/>
> NTT Communication Science Laboratories | Natural Language Research Group

--Eric Nichols

More information about the developers mailing list