[developers] [spr30362] bug using climxm

Berthold Crysmann crysmann at dfki.de
Fri Sep 22 14:50:24 CEST 2006

Andreas Fuchs wrote:
> On 2006-09-13, Ben Waldron <bmw20 at cl.cam.ac.uk> wrote:
>> Hi Andreas -
> Hi Ben,
>> Thanks for this email. Unfortunately, the patch is not working for
>> us:
> I think I now have a fix that should do the right thing if
> excl:*locale* is rebound. To test it, replace the old patch.lisp with
> the attached file, and compile & load the file before starting your
> application.
> ------------------------------------------------------------------------
> This patch outputs a bit of debug information when going through
> the locale possibilities on application startup.
> There is one important thing to note, though: Due to an XT limitation,
> the application must set or bind excl:*locale* to the correct value
> before the first application frame is created and the port is
> initialized.
> Regards, Andreas.
Dear ,

I have tried this new patch but, unfortunately, the behaviour has not 
changed (apart from an error message).
This is what I did:

Start clim with C.UTF-8 locale

/usr/local/acl80/bclim -locale C.UTF-8

My .clinit.cl looks like this:
(in-package "COMMON-LISP-USER")

(system:resize-areas :new (* 384 1024 1024) )

(setf (sys:gsgc-parameter :expansion-free-percent-new) 5)
(setf (sys:gsgc-parameter :expansion-free-percent-old) 5)
(setf (sys:gsgc-parameter :free-percent-new) 2)

(pushnew :psql *features*)
(pushnew :lkb *features*)

(load "/home/crysmann/patch.lisp")

(load "/home/crysmann/lkb/src/general/defsystem.lisp")
(load "/home/crysmann/lkb/src/general/loadup")


I then compiled and ran our application.

Opening the relevant input widget (Parse input ...) I tried to enter a 
simple German sentence "Er schläft."

Problem 1: Keyboard input of "ä" (Compose+"+a) did not work at all 
(nothing inserted). (I checked this "adding" trailing Umlauts to other 
Problem 2: Pasting the string with the mouse (button 2) Only shows the 
characters to the left of the umlaut in the input widget and an error 

Error: Error reading mb-vector from
         #<EXCL:BUFFER-INPUT-SIMPLE-STREAM pos 7 @ #x6daf746a>


Berthold Crysmann

More information about the developers mailing list