[developers] bulk export from tsdb

Stephan Oepen oe at ifi.uio.no
Mon Oct 22 10:01:56 CEST 2012

hi megan,

yes, as francis suggests, the ‘illegal keyword’ error points
to an out-of-date LOGON tree.  there was a period of some
months earlier this year, i think, when the ‘redwoods’ script
and 32-bit run-time binaries were not synchronized.

could you check the SVN revsion you have, in particular:

0 oe at mv (~/) 57 $ svn info $LOGONROOT/lingo/lkb/linux.x86.32/logon.dxl
Path: /home/oe/src/logon/lingo/lkb/linux.x86.32/logon.dxl
Name: logon.dxl
URL: http://logon.emmtee.net/trunk/lingo/lkb/linux.x86.32/logon.dxl
Repository Root: http://logon.emmtee.net
Repository UUID: 3df82f5b-d43a-0410-af33-fce91db48ec5
Revision: 11901
Node Kind: file
Schedule: normal
Last Changed Author: oe
Last Changed Rev: 11688
Last Changed Date: 2012-08-12 11:54:30 +0200 (Sun, 12 Aug 2012)
Text Last Updated: 2012-08-12 12:06:26 +0200 (Sun, 12 Aug 2012)
Checksum: ef008df14315efe4c01ee908523e918c

once you upgrade to the current LOGON revision, i expect the
setup you describe should work fine.  the profiel name you pass
as the final argument to the ‘redwoods’ scripts needs to be valid
relative to the database home, which in ‘--terg’ mode defaults to
$LOGONROOT/lingo/terg/tsdb/home/ ... so a soft link in the right
place should do the trick, i should think :-).

best, oe

On Sun, Oct 21, 2012 at 11:14 PM, Megan Schneider <caelum at gmail.com> wrote:
> Greetings,
> I have been attempting to use the redwoods script in logon to bulk export
> tsdb results with a slightly modified ERG that is sitting in the terg
> directory. The only difference between it and the normal ERG is a modified
> labels file. I can get the instructions at
> http://moin.delph-in.net/ItsdbTreebanking/ItsdbExporting to work but while
> that works for a single export, it does use enough memory to force me to
> restart the stack after each export. The link at the bottom of that page
> with reference to bulk exporting is http://moin.delph-in.net/RedwoodsTop,
> which seems to point to http://moin.delph-in.net/WeScience and the section
> on exporting using the redwoods script. I have tried several variations but
> don't actually have an idea of what the full usage of the script is. This is
> somewhat complicated by having the tsdb data in a completely separate
> directory (it's living on my storage array). The --terg option appears to
> set the tsdb home to $LOGONROOT/lingo/terg/tsdb/gold, so I symlinked that to
> the appropriate storage array directory that actually contains the data I
> want.
> I've tried
> ./redwoods --binary --terg --target <output directory> --export
> derivation,tree,mrs <tsdb test suite instance name>
> but again I have no idea if this is actually correct usage. I have attached
> the output from running the command; it ends with:
>  TSNLP(9): Error: Illegal keyword given: :BLINDP.
>   [condition type: PROGRAM-ERROR]
> and I have no idea where to go from there. If anyone has any clues, I'd very
> much appreciate them. Especially if anyone knows how to do a
> bulk/command-line export, with or without the redwoods script.
> Thanks,
> Megan Schneider

More information about the developers mailing list