[developers] bulk export from tsdb

Francis Bond bond at ieee.org
Mon Oct 22 04:10:25 CEST 2012


It looks to me as though you are doing things basically right.  I
don't have anything in terg, but running the similar:
./redwoods --binary --erg --target /tmp --export 'derivation,tree,mrs' mrs
works fine for me.

:blindp is being called in the epilog of the redwoods script.  A brute
force approach would be to just delete ":blindp ${blind}" from the
script.  I suspect it means that somehow your tsdb is out of date,
maybe updateing everything with a 'make update' from $LOGONROOT would
solve your problems.

On 22 October 2012 05:14, Megan Schneider <caelum at gmail.com> wrote:
> Greetings,
> I have been attempting to use the redwoods script in logon to bulk export
> tsdb results with a slightly modified ERG that is sitting in the terg
> directory. The only difference between it and the normal ERG is a modified
> labels file. I can get the instructions at
> http://moin.delph-in.net/ItsdbTreebanking/ItsdbExporting to work but while
> that works for a single export, it does use enough memory to force me to
> restart the stack after each export. The link at the bottom of that page
> with reference to bulk exporting is http://moin.delph-in.net/RedwoodsTop,
> which seems to point to http://moin.delph-in.net/WeScience and the section
> on exporting using the redwoods script. I have tried several variations but
> don't actually have an idea of what the full usage of the script is. This is
> somewhat complicated by having the tsdb data in a completely separate
> directory (it's living on my storage array). The --terg option appears to
> set the tsdb home to $LOGONROOT/lingo/terg/tsdb/gold, so I symlinked that to
> the appropriate storage array directory that actually contains the data I
> want.
> I've tried
> ./redwoods --binary --terg --target <output directory> --export
> derivation,tree,mrs <tsdb test suite instance name>
> but again I have no idea if this is actually correct usage. I have attached
> the output from running the command; it ends with:
>  TSNLP(9): Error: Illegal keyword given: :BLINDP.
>   [condition type: PROGRAM-ERROR]
> and I have no idea where to go from there. If anyone has any clues, I'd very
> much appreciate them. Especially if anyone knows how to do a
> bulk/command-line export, with or without the redwoods script.
> Thanks,
> Megan Schneider

Francis Bond <http://www3.ntu.edu.sg/home/fcbond/>
Division of Linguistics and Multilingual Studies
Nanyang Technological University

More information about the developers mailing list