[developers] Running LKB in tty mode

Glenn Slayden glenn at thai-language.com
Thu May 2 03:41:03 CEST 2013

Hello Mostafa,
Since you don't need generation support, you can use any of the four DELPH-IN parsers. I am aiming to have a first supported release
of 'agree' available this summer. Until that time, the current sources can be obtained without support by contacting me. 
ACE and PET have stable releases, and can also produce the MRS output you require with maximum real-time performance. Because the
rest of your system uses LISP, continuing to use the LKB seems like a good fit. Emily's suggestion of KNOPPIX+LKB is a hassle-free
route to LKB.
We welcome your participation in the DELPH-IN community!
From: developers-bounces at emmtee.net [mailto:developers-bounces at emmtee.net] On Behalf Of Mostafa Gomaa
Sent: Wednesday, May 01, 2013 6:31 AM
To: Emily M. Bender
Cc: developers at delph-in.net
Subject: Re: [developers] Running LKB in tty mode
Dear Emily,
My goal is to get MRS output from LKB and represent it in SNePS (Semantic network processing system) which is another system written
in common lisp  http://www.cse.buffalo.edu/sneps/
Thanks for the suggestions, If all fails, I'll check out the other processors. Is there any particular processor you'd recommend for
my case?. Thank you for your time.
Mostafa Gomaa
On Wed, May 1, 2013 at 3:17 PM, Emily M. Bender <ebender at uw.edu> wrote:
Dear Mostafa,

Can you tell us about your goals with using this software?
Are you planning to develop a new grammar or run with existing
grammars?  In the case of the former, the KNOPPIX+LKB VirtualBox
appliance might be a good solution:


In case of the latter, you might investigate the other
DELPH-IN processors.


On Wed, May 1, 2013 at 6:01 AM, Mostafa Gomaa <mostafa.gomaa89 at gmail.com> wrote:
> Hello,
> After too much effort of attempting to compile LKB under windows using SBCL,
> I was finally able to compile it. I mainly followed the error messages, did
> some tweaks and edited some character encoding errors. I also played around
> with the system files a bit. The problem now is that I want to load and use
> a grammar in tty mode. I first tried to load the script file using
> (read-script-file-aux path-to-file), but now I receive some errors when the
> function is attempting to read the types.tdl file. The errors are as
> follows:
> Reading in type file types
> Checking type hierarchy
> *DLIST* specified to have non-existent parent *TOP*
> *LIST* specified to have non-existent parent *TOP*
> AGR specified to have non-existent parent *TOP*
> POS specified to have non-existent parent *TOP*
> RELATION specified to have non-existent parent *TOP*
> SEMANTICS specified to have non-existent parent *TOP*
> SEMENT specified to have non-existent parent *TOP*
> SIGN specified to have non-existent parent *TOP*
> STRING specified to have non-existent parent *TOP*
> debugger invoked on a SIMPLE-ERROR in thread
> #<THREAD "main thread" RUNNING {23EF7981}>:
>   Problems in type file
> Any ideas on how this may be solved?. Thank you very much.
> Regards,
> Mostafa Gomaa

Emily M. Bender
Associate Professor
Department of Linguistics
Check out CLMS on facebook! http://www.facebook.com/uwclma
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.delph-in.net/archives/developers/attachments/20130501/31853ecc/attachment-0001.html>

More information about the developers mailing list