[developers] terg in the LOGON tree

Stephan Oepen oe at ifi.uio.no
Fri Mar 15 07:39:54 CET 2019

hi alexandre,

i can reproduce the issue you describe on one of my linux environments,
while the instructions as published work fine on others.  it appears newer
versions of the SVN client enforce some testing that gets in the way.  and
for all i can tell right now, that is an unwarranted error report.

either way, the problem goes away when i follow the instructions from SVN,
i.e. add ‘—ignore-ancestry’ to the ‘switch’ command.  could you try that
too and report back?  if it works for you too, i shall update the
LogonExtras page.

in general, you need to use the same base SVN address as for the original
‘checkout’, ‘http://svn.emmtee.net’ for most people.  the purpose of the
LOGONSVN environment variable is to enforce such uniformity of SVN access

so please just try the command from the LogonExtras page, with the addition
of the ‘—ignore-ancestry’ switch.

cheers, oe

On Fri, 15 Mar 2019 at 03:18 Alexandre Rademaker <arademaker at gmail.com>

> Hi all,
> I am trying to experiment PET, distributed in the LOGON tree, with the
> last version of ERG (trunk). I tried to understand the process reading of
> having terg in the LOGON tree the following pages:
> [1] http://moin.delph-in.net/LogonInstallation
> [2] http://moin.delph-in.net/LogonExtras
> [3] http://moin.delph-in.net/ErgTop
> In [1] it says to install LOGON with the following command:
> svn checkout http://svn.emmtee.net/trunk logon
> In [2], section `Test Version of the ERG (Public)` we have the mention to
> `SVNROOT` and in the beginning of the page, the sentence:
> > Due to what appears to be a quirk in how SVN handles mixed-access
> repositories (i.e. repositories where some content is available to
> anonymous users, while other parts require user authentication), LOGON
> co-developers with SVN user accounts should connect through a different
> URL, viz. http://logon.emmtee.net/
> > ...In the following examples, we use the environment variable $LOGONSVN
> instead of a specific SVN base URL
> My first try was:
> $ svn switch http://svn.emmtee.net/erg/trunk .
> svn: E195012: Path '.' does not share common version control ancestry with
> the requested switch location.  Use --ignore-ancestry to disable this check.
> svn: E195012: 'http://svn.emmtee.net/erg/trunk' shares no common ancestry
> with '/Users/ar/hpsg/logon/lingo/terg’
> I also tried the URL in page [3], with the error:
> $ svn switch http://svn.delph-in.net/erg/trunk .
> svn: E155025: 'svn switch' does not support switching a working copy to a
> different repository
> svn: E155025: 'http://svn.emmtee.net/trunk/lingo'
> is not the same repository as
> 'http://svn.delph-in.net’
> Unfortunately, the url `http://logon.emmtee.net/erg/trunk`
> <http://logon.emmtee.net/erg/trunk> requires authentication and I don’t
> have an account on this server. But consider the name of the section `Test
> Version of the ERG (Public)`, does it make sense to make it available only
> to authenticated users? Does ERG source is at
> http://logon.emmtee.net/erg/trunk and http://svn.delph-in.net/erg/trunk?
> Best,
> --
> Alexandre Rademaker
> http://arademaker.github.io
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.delph-in.net/archives/developers/attachments/20190315/922f8f81/attachment-0001.html>

More information about the developers mailing list