[developers] Mysterious Japanese grammar hang

Francis Bond bond at ieee.org
Tue Jul 14 09:47:28 CEST 2009


CCed to developers in the interest of greater openness.

2009/7/14 W.P. McNeill (UW) <billmcn at u.washington.edu>:
> The
> Japanese parse ranking experiment that you helped me set up mysteriously stopped working over the weekend.  I haven't changed anything in the setup since the time that it worked, so I presume something else in the system around it changed.
> When I try to run a Tanaka grid point with the load script it hangs at the following point during grammar loading:
> ...
> Checking type hierarchy
> Checking for unique greatest lower bounds
> Expanding constraints
> Making constraints well formed
> [12:07:11] gc-after-hook(): {L#32 N=43m O=0 E=66%} [S=891m R=203m].
> [12:07:12] gc-after-hook(): {L#33 N=68m O=0 E=39%} [S=891m R=283m].
> Expanding defaults
> Type file checked successfully
> Computing display ordering
> A full log is attached.
> The process appears to be hung because yzlui is waiting for input from

If you aren't using LUI, I recommend adding "unset LUI" to your
script.  Saves some CPU and may have other beneficial effects.

> Do you have any idea what is going on here?  The only thing that has changed
> is that the sys admin did some file system reconfiguration.  It shouldn't
> make a difference, but I'm wondering if there's some set of cached files
> that the Japanese grammar needs that it can no longer see.
> My workaround is to remove the line that loads the grammar from the load
> script, but I'd like to know what is going wrong here.

I'm not really sure.  Does the grammar load OK interactively?  I tried
that version on a recent logon, and it loaded with no problems,
although I didn't try a batch.

Francis Bond <http://www3.ntu.edu.sg/home/fcbond/>
Division of Linguistics and Multilingual Studies
Nanyang Technological University

More information about the developers mailing list