[developers] Problem with cheap and -tsdbdump

Petter Haugereid petterha at gmail.com
Fri Nov 11 05:41:02 CET 2011

Dear developers,

We have a problem using cheap with -tsdbdump parsing a file of 1500
sentences with the ERG. (I have attached the file.)

If we give the following command:

cheap -repp -tagger -cm -default-les=all -timeout=60 -packing
-memlimit=1024 -tsdbdump=erg_dumped/ -inputfile=rtc_006

All the 1500 sentences are parsed. (They appear in `item' and
`parse'.) But not everything is printed into `result'. It stops in the
middle of 1094 at 8964, at 2,147,483,647 bytes. There seems to be a limit
to how much you can write into `result'. We have tried several times
on different machines, and it always stops at this point. We have also
tried to reshuffle the sentences in the input file, but still the
result file stops at 2,147,483,647 bytes.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: rtc_006
Type: application/octet-stream
Size: 63329 bytes
Desc: not available
URL: <http://lists.delph-in.net/archives/developers/attachments/20111111/ec6dd816/attachment.obj>

More information about the developers mailing list