[developers] Interactive MT not working on KNOPPIX+LKB

Woodley Packard sweaglesw at sweaglesw.org
Wed May 22 07:07:15 CEST 2013

Dear Emily,

I believe the problem is the empty characterization <>'s after the EP names in the MRS output from the source grammar.  Have you tried adding the following to lkb/mrsglobals.lsp on the source side?

(setf *show-lnk-p* nil)

This worked for me, on KNOPPIX+LKB.

On May 21, 2013, at 9:46 PM, Emily M. Bender wrote:

> Dear all,
> We've gotten to the MT portion of Ling 567 at UW, and discovered
> that the MT set up on the KNOPPIX+LKB system isn't working.  Specifically:
> I have the students start with and eng<>ita pair that I know works.
> (And Ned at least has it working on LOGON trunk currently.)  They
> set up two emacsen, load the source and target grammars, and start
> the generator server on the target side.  The values for *translate-grid*
> are set appropriately.  
> When we parse a sentence in the source grammar and select "rephrase",
> the target side emacs reports "read 0 MRSs are generator input".  I've
> seen this work with exactly this pair of grammars in past years (and
> Ned is seeing it work this year), so I suspect the problem has something
> to with the file encoding of the .translate.<user>.<iso> file.  I've
> captured one of those by turning off the generator server, and it is attached.
> (I had to rename it to be able to upload it into gmail for some reason;
> the actual file name was as expected.)
> Another symptom is that Generate | Display input MRS does nothing,
> which suggests that the MRS isn't properly imported --- the grammar doesn't
> get a chance to try generating from it.  For completeness, I put the same
> grammar (eng) on both sides (and updated *translate-grid* appropriately).
> Same behavior.
> Here is a little bit more info:
> LKB(5): (trace mrs::read-mrss-from-file)
> LKB(6): 
>  0[5]: (MRS::READ-MRSS-FROM-FILE #P"/home/ubuntu/tmp/.transfer.ubuntu.ita")
>  0[5]: returned NIL #<SIMPLE-ERROR @ #x4bea3d6a>
> [21:32:27] translate(): read 0 MRSs as generator input.
> LKB(6): (trace mrs::read-mrs-stream)
> LKB(7): 
>  0[5]: (MRS::READ-MRSS-FROM-FILE #P"/home/ubuntu/tmp/.transfer.ubuntu.ita")
>                                  #P"/home/ubuntu/tmp/.transfer.ubuntu.ita" for input pos 0
>                                  @ #x4beb10a2>)
>    1[5]: returned-by-throwing to tag IGNORE-ERRORS-1: NIL
>            #<SIMPLE-ERROR @ #x4beb3d12>
>  0[5]: returned NIL #<SIMPLE-ERROR @ #x4beb3d12>
> [21:33:41] translate(): read 0 MRSs as generator input.
> LKB(7): 
> Any ideas on what might be going on here, and what kind of work-around I 
> can offer the students?
> Many thanks,
> Emily
> -- 
> Emily M. Bender
> Associate Professor
> Department of Linguistics
> Check out CLMS on facebook! http://www.facebook.com/uwclma
> <dot.transfer.ubuntu.ita>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.delph-in.net/archives/developers/attachments/20130521/10c90fec/attachment.html>

More information about the developers mailing list