[developers] Empty file named ... at logon/uio/test/logs/

David Brodbeck brodbd at uw.edu
Tue Oct 6 19:06:58 CEST 2015

Out of curiosity I tried creating a file named "..." under Windows.  It
didn't give me an error, but the file didn't seem to exist, except that I
couldn't create a directory with the same name ("file or directory exists.")

I was able to create one under cygwin, but the Windows command prompt again
didn't show it and gave "access denied" when I tried to look at it.

It's a valid filename in Linux, but clearly there's something weird about
how Windows handles it.

On Tue, Oct 6, 2015 at 9:26 AM, Stephan Oepen <oe at ifi.uio.no> wrote:

> hi emily and laurie,
> > There seems to be an empty file called '...' in the LOGON svn,
> > which is leading to problems (see below).  Can this be removed?
> i just removed that file; it was residual from the times when the
> LOGON tree was versioned in CVS, to include the otherwise empty
> directory in the repository.
> out of curiosity, however, does removing this file really resolve your
> problems?  the file name ‘...’ seems perfectly legitimate (if somewhat
> creative) to me, and those periods all are plain ASCII, i.e. i wonder
> how your SVN client would consider them ‘invalid characters’?  also,
> this file has been around for decades and not caused problems in the
> past (for all i know).  so, please keep me posted in case your problem
> persists ...
> best, oe

D. Brodbeck
System Administrator, Linguistics
University of Washington
GPG key fingerprint: 0DB7 4B50 8910 DBC5 B510 79C4 3970 2BC3 2078 D875
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.delph-in.net/archives/developers/attachments/20151006/dae9c02f/attachment.html>

More information about the developers mailing list