[developers] text analysis advice

#KANG NI YING BIANCA# KANG0093 at e.ntu.edu.sg
Wed Aug 22 10:37:11 CEST 2018

Thank you, Dr Emerson, for the suggestion of VirtualBox! With it I managed to get the local server running on Ubuntu and can now successfully use it with the REST interface on Windows.

I get an ERROR:root:Malformed output from ACE: each time I ask ACE to parse something, but the sentence still gets parsed and the output returned seems to be alright. Specifically I am just checking for imperatives; comparing a few runs against the output I got from using http://chimpanzee.ling.washington.edu/bottlenose/erg/parse gives me the same results. I think in this case I do not have to be too concerned about that error message? Please do correct me if I am mistaken about this.

Thank you again for all the advice and help!



From: Guy Emerson <gete2 at cam.ac.uk>
Sent: Monday, August 20, 2018 9:00:32 PM
Cc: #KANG NI YING BIANCA#; developers
Subject: Re: [developers] text analysis advice

That looks like the same error I was getting before.  I never managed to get further, although I haven't tried again since that last thread.  If you are interested, you could try running gdb and consulting the thread (look at the last couple of messages) to see if it's crashing at the same place.  Regardless of where it is crashing, it is probably because some Linux functionality is still missing.  If you're using the most up-to-date version of WSL, then there's not much you can do without delving into the details of WSL.  I don't think anyone on the developers list (including myself) knows enough about WSL to do this.

The only reliable way I know of running ACE on Windows is to use a VirtualBox.

Am So., 19. Aug. 2018 um 17:58 Uhr schrieb goodman.m.w at gmail.com<mailto:goodman.m.w at gmail.com> <goodman.m.w at gmail.com<mailto:goodman.m.w at gmail.com>>:
Hi Bianca,

I'm bringing in the developers mailing list (you may need to subscribe in order to reply: http://lists.delph-in.net/mailman/listinfo/developers) as someone on the list may have more information.

Developers, Bianca wants to run ACE on Ubuntu on WSL. I recall that Guy et al. made some progress on that front almost 2 years ago (see this thread: http://lists.delph-in.net/archives/developers/2016/002372.html), but have things improved since then?

Bianca, PyDelphin builds on top of ACE's stdin/stdout interface, and Bottlenose on top of PyDelphin, so this is why you see the same error for all 3 invocations of ACE.

On Sun, Aug 19, 2018 at 8:49 AM #KANG NI YING BIANCA# <KANG0093 at e.ntu.edu.sg<mailto:KANG0093 at e.ntu.edu.sg>> wrote:

Dear Dr Goodman,

Apologies for another email - I found out I could try to run Ubuntu as a subsystem on Windows to give the Linux server a go, but ran into an error (deadly signal and malformed ACE output).

I downloaded the pre-compiled ACE and ERG following http://moin.delph-in.net/QuickStart (the 0.9.27 versions) and also downloaded Bottlenose, Bottle and PyDelphin following http://moin.delph-in.net/FrancisBond

These are the instances where I tried ACE; I hope the following screens will be helpful -

1)Following the syntax on the Quickstart guide to check if ACE and ERG are working:


2)Trying to use the ACE interface:


3)Setting up the local server and connecting to it on the iPython notebook:


Are there any other files which I should have downloaded/steps I should have taken to avoid this error?

Thank you again for your advice! Please let me know if you require more information - I am new to this but will do my best to provide it.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.delph-in.net/archives/developers/attachments/20180822/a1c29903/attachment.html>

More information about the developers mailing list